The Microsoft.Jet.OLEDB.4.0'provider is not registered on the local machine

From Sage Intelligence Knowledgebase
Jump to: navigation, search

There is no 64 bit version of jet that is why you receive this error.

To force your application to use the 32 bit, change the target cpu to x86 in the advanced compiler options.