Difference between revisions of "ACCESS IN SECURITY MANAGER REMOVED BUT REPORTS ARE STILL ABLE TO BE RUN"

From Sage Intelligence Knowledgebase
Jump to: navigation, search
Line 18: Line 18:
 
[http://www.alchemex.org/SoftwareDownloads/Hotfixes/SageIntelligenceHotfix12671.exe Hotfix Sage 300 ERP 2012] to be installed on any full install of Sage 300.
 
[http://www.alchemex.org/SoftwareDownloads/Hotfixes/SageIntelligenceHotfix12671.exe Hotfix Sage 300 ERP 2012] to be installed on any full install of Sage 300.
  
[http://www.alchemex.org/SoftwareDownloads/Hotfixes/SageIntelligenceCertificateInstaller.exe Hotfix for Sage 300 ERP 2012 workstation install] to be installed on ALL workstation setups.
+
[http://www.alchemex.org/SoftwareDownloads/Hotfixes/SageIntelligenceCertificateInstaller.exe Hotfix Sage 300 ERP 2012 workstation install] to be installed on ALL workstation setups after the hotfix above has been.
  
 
This hotfix must be installed in the installation directory of the Sage 300 ERP.
 
This hotfix must be installed in the installation directory of the Sage 300 ERP.

Revision as of 07:53, 25 June 2014

ISSUE: ACCESS IN SECURITY MANAGER REMOVED BUT REPORTS ARE STILL ABLE TO BE RUN


SYMPTOMS:

Creating a role that has access to selected reports, assign a user to the role and when logged in as the limited user still manage to run all reports.


CAUSE:

When synchronizing users (between Sage 300 and Alchemex svd) the non-admin users get assigned to a ‘Report Users’ role which does not show in the list of roles (in Security Manager). This role can run all reports and hence when our software does a security check, it picks up this role first and ignores any other role assignment done later. This then allows the user to run all reports in the ERP even though they may be assigned to a role that can only run few reports.


RESOLUTION/WORKAROUND:

Clients experiencing this problem should install a hotfix found here:

Hotfix Sage 300 ERP 2012 to be installed on any full install of Sage 300.

Hotfix Sage 300 ERP 2012 workstation install to be installed on ALL workstation setups after the hotfix above has been.

This hotfix must be installed in the installation directory of the Sage 300 ERP.


APPLIES TO:

Sage 300 ERP 2012